dana banana (xx_rapunzel_xx) wrote in mac_osx,
dana banana
xx_rapunzel_xx
mac_osx

Adobe Flash Player/Plug-in

Hey guys, I'm new here :)

I'm an idiot when it comes to downloading software, so here's my problem: I have an iBook G4 that's pretty old. Lately I can't watch TV episodes online (at least on the ABC and NBC sites) 'cause I don't have the latest version of Adobe Flash Player or whatever it is. I just tried to access the ABC site, which gave me directions on how to download the latest version. So I start to download it, but then it gives me a message that it can only install on Macs 10.4 (?) or higher and not any earlier versions. :(

So... what does this mean? System upgrade? Time to get a new laptop? What should I do? The Mac software site and download.com doesn't really help in this matter.

Thanks for any help you can give me!
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 2 comments